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Chapter 1

Introduction

NeuroView is a Windows application that allows you to:

1. Connect to inkGear modules/headsets through the COM ports on your computer

2. Record data from connected inkGear modules/headsets into log ëles, which can then be
opened in Excel, MATLAB, or other programs for further analysis

3. View data in meters and graphs received in real-time from connected inkGear modules/head-
sets for immediate feedback during data collection experiments

4. Send Command Bytes to connected inkGear modules/headsets to customize and conëgure
them (such as enabling raw sampling wave output on headsets that do not output raw wave data
by default)

is User's Guide will show you how to install, run, and use NeuroView to perform the tasks described
above.
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Chapter 2

Installation

NeuroView is distributed as a Research tool as part of NeuroSky's MindSet Research Tools (MRT).

To install NeuroView, browse to the MindSet Research Tools/NeuroView/ directory in the MRT,
and run the setup.exe program located there. e installer will copy NeuroView to your Program
Files, along with any required .dll ëles. It will also create a NeuroView program group in your Start
menu, and a shortcut on your desktop.
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Chapter 3

Running NeuroView

To run NeuroView, double-click on the NeuroView icon on your desktop, or click on All Programs
> NeuroSky > NeuroView in your Start Menu.
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Chapter 4

Connecting To A Data Source

NeuroView is able to connect to, and read data from, any inkGear module or headset that is con-
nected to one of the Operating System's COM ports.

1. Make sure the inkGear module or headset is turned on and is actually connected to a COM
port on the system that NeuroView is running on.

• inkGear modules or headsets connected though Bluetooth must already be paired and
authenticated with key "0000", with Bluetooth SPP service detected by the system's Blue-
tooth stack, in order for NeuroView to be able to connect.

• Please refer to the MindSet Quick Start Guide, or other documentation that accompanied
your inkGear module or headset, for detailed instructions on how to properly connect
your module or headset to your system's COM ports (referred to as headset "Pairing" or
"Setup").

2. Select File > Connect (or click the Connect icon on the toolbar) in NeuroView to bring up the
Connection dialog.

3. Select the correct name of the COM port that the inkGear is connected to.

• Again, please refer to the MindSet Quick Start Guide, or other documentation that ac-
companied your inkGear module or headset, for detailed instructions on how determine
which COM port your module or headset is connected to (for Bluetooth connections, it
may be referred to as the "Outgoing Port").

• If you know the name or number of the COM port, you can type either the name, or even
just the number, directly into the ëeld (If typing the name, remember that on Windows
systems, COM port 10 and higher are named like \\.\COM10).

4. Select the correct communication baud rate for your inkGear module.

• Standard MindSet headsets are conëgured to communicate at 57600 baud, while some
older inkGear modules and headsets may be conëgured to be 9600 baud. Refer to the
documentation that accompanied your module or headset or purchase to determine the
baud rate it was conëgured for at the factory.

• Remember, if you previously changed the conëguration of your module or headset by
sending it a Command Byte, then as long as the module or headset stays powered on, it
will continue operating with the conëguration you instructed it to, even if you close the
NeuroView application, so be sure to have NeuroView attempt to connect at the baud
rate of the current conëguration. To reset a module or headset back to its original factory
conëguration, simply turn the module/headset completely off, and then back on.

5. Click OK to attempt the connection.

• If unable to open the selected COM port, or if inkGear data cannot be detected on the
selected COM port, a message will pop up indicating the problem, and suggestions for
resolving the problem.
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Chapter 4 – Connecting To A Data Source

6. Select File > Disconnect (or click the Disconnect icon on the toolbar) to disconnect from the
inkGear.
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Chapter 5

Real-time Data Viewing/Graphing

Graphs, meters, and messages show you the data that NeuroView is receiving from the inkGear
module/headset in real-time. Most inkGear modules and headsets are conëgured at the factory to
at least output Attention, Meditation, and Poor Signal Quality by default. Other types of data may
be requested by sending certain Command Bytes to the system (only applicable to certain hardware
models, see Sending Command Bytes for details).

Poor Signal Quality Messages

e status bar at the bottom of the window will continually display Poor Signal Quality messages sent
from the inkGear module/headset. A Poor Singal Quality value of 0 indicates a relatively clean
signal, while higher values indicate progressively poorer signals. A value of 200 has a special meaning,
namely that the electrodes of the inkGear module/headset are not contacting the skin of the head
at all.

Poor signal may be caused by a number of different things. In order of severity, they are:

• Sensor, ground, or reference electrodes not being on a person's head (i.e. when nobody is wearing
the inkGear).

• Poor contact of the sensor, ground, or reference electrodes to a person's skin (i.e. hair in the
way, or headset which does not properly ët a person's head, or headset not properly placed on
the head).

• Excessive motion of the wearer (i.e. moving head or body excessively, jostling the headset).

• Excessive environmental electrostatic noise (some environments have strong electric signals or
static electricity buildup in the person wearing the sensor).

• Excessive non-EEG biometric noise (i.e. EMG, EKG/ECG, EOG, etc)

A certain amount of noise is unavoidable in normal usage of inkGear, and both NeuroSky's ëlter-
ing technology and eSense™ algorithm have been designed to detect, correct, compensate for, account
for, and tolerate many types of non-EEG noise. Most typical users who are only interested in us-
ing the eSense values, such as Attention and Meditation, do not need to worry too much about the
POOR_SIGNAL Quality value, except to note that the Attention and Meditation values will not be
updated while POOR_SIGNAL is detected. e POOR_SIGNAL Quality value is more useful to some
applications which need to be more sensitive to noise (such as some medical or research applications),
or applications which need to know right away when there is even minor noise detected.

eSense™ Meters

Select View > Attention eSense Meter or View > Meditation eSense Meter (or click the corre-
sponding toolbar button) to view Attention or Meditation meter values sent from the inkGear
module/headset.

June 28, 2009 | © 2009 NeuroSky, Inc. All Rights Reserved.
9

http://www.neurosky.com


Chapter 5 – Real-time Data Viewing/Graphing

For all the different types of eSenses (i.e. Attention, Meditation), the meter value is reported on a
relative eSense scale of 1 to 100. On this scale, a value between 40 to 60 at any given moment in time
is considered "neutral", and is similar in notion to "baselines" that are established in conventional EEG
measurement techniques (though the method for determining a inkGear baseline is proprietary and
may differ from conventional EEG). A value from 60 to 80 is considered "slightly elevated", and may
be interpreted as levels being possibly higher than normal (levels of Attention or Meditation that may
be higher than normal for a given person). Values from 80 to 100 are considered "elevated", meaning
they are strongly indicative of heightened levels of that eSense.

Similarly, on the other end of the scale, a value between 20 to 40 indicates "reduced" levels of the
eSense, while a value between 1 to 20 indicates "strongly lowered" levels of the eSense. ese levels
may indicate states of distraction, agitation, or abnormality, according to the opposite of each eSense.

An eSense meter value of 0 is a special value indicating the inkGear is unable to calculate an eSense
level with a reasonable amount of reliability. is may be (and usually is) due to excessive noise as
described in the POOR_SIGNAL Quality section above.

e reason for the somewhat wide ranges for each interpretation is that some parts of the eSense
algorithm are dynamically learning, and at times employ some "slow-adaptive" algorithms to adjust
to natural ìuctuations and trends of each user, accounting for and compensating for the fact that
EEG in the human brain is subject to normal ranges of variance and ìuctuation. is is part of the
reason why inkGear sensors are able to operate on a wide range of individuals under an extremely
wide range of personal and environmental conditions while still giving good accuracy and reliability.
Developers are encouraged to further interpret and adapt these guideline ranges to be ëne-tuned for
their application (as one example, an application could disregard values below 60 and only react to
values between 60-100, interpreting them as the onset of heightened attention levels).

ATTENTION eSense
is unsigned one-byte value reports the current eSense Attention meter of the user, which indi-
cates the intensity of a user's level of mental "focus" or "attention", such as that which occurs during
intense concentration and directed (but stable) mental activity. Its value ranges from 0 to 100. Dis-
tractions, wandering thoughts, lack of focus, or anxiety may lower the Attention meter levels. See
eSense\texttrademark Meters above for details about interpreting eSense levels in general.

MEDITATION eSense
is unsigned one-byte value reports the current eSense Meditation meter of the user, which indicates
the level of a user's mental "calmness" or "relaxation". Its value ranges from 0 to 100. Note that
Meditation is a measure of a person's mental levels, not physical levels, so simply relaxing all the
muscles of the body may not immediately result in a heightened Meditation level. However, for
most people in most normal circumstances, relaxing the body often helps the mind to relax as well.
Meditation is related to reduced activity by the active mental processes in the brain, and it has long
been an observed effect that closing one's eyes turns off the mental activities which process images
from the eyes, so closing the eyes is often an effective method for increasing the Meditation meter level.
Distractions, wandering thoughts, anxiety, agitation, and sensory stimuli may lower the Meditation
meter levels. See eSense Meters above for details about interpreting eSense levels in general.

Graphs

Select any of the Graphs under the View menu (or click the corresponding toolbar button) to toggle
show/hide the selected graph.

Graphs
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Chapter 5 – Real-time Data Viewing/Graphing

For each graph, you may adjust the maximum and minimum displayed ranges of the X and Y axis,
allowing you to zoom in and out of each graph as desired.

NOTE: e Power Spectrum in NeuroView is calculated from the Filtered Wave, which in turn is
calculated from the Raw Wave. So in order for the Raw Wave Graph, Filtered Wave Graph, and Power
Spectrum Graphs to have any data to display, NeuroView must be receiving Raw Wave information
from the inkGear module or headset. However, because many applications do not require Raw
Wave information, or don't have the ability to use it in any meaningful way, some inkGear modules
and headset models are conëgured to not output Raw Wave information by default. If this is the case
with your module/headset, refer to the Sending Command Bytes section for information on how to
enable it, based on the module/headset that you have.

Graphs
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Chapter 6

Recording Data Logs

To begin recording data, select Record > Start Recording from the menu (or click the red Record
button on the toolbar). Any data received by NeuroView from that moment on will be recorded to
temporary ëles in the program's execution directory. You can Start Recording even before a connection
to a COM port is established, in which case data will begin to be recorded to the temporary ëles as
soon as a connection is made and data is received.

Recording Options

You may customize the recorded ële formats in several ways. Typically, you should select your record-
ing settings before clicking Start Recording, although it is possibly to change the settings at any time
during a recording. Note that some options are enabled only if other options are enabled ërst.

• UNIX Timestamps - e recorded log ëles will use UNIX-style timestamps, which are deëned
as the "number of seconds since the EPOCH, Jan 1, 1970, 0:00". ese timestamps are in units
of seconds, with 3 decimal places, so that they actually provide up to millisecond precision. If
UNIX Timestamps are not enabled, then HH:MM:SS format will be used for the timestamps
instead.

• Relative Time - e recorded log ëles will use timestamps indicating relative time, deëned as
"number of seconds from the time the ërst data Packet was received from the inkGear mod-
ule/headset".

• Reset Relative Time - Resets the relative time to zero each time the Start Recording is pressed,
instead of each time the program is started.

• MATLAB formatting - Comments out the CSV header line using a MATLAB-style comment
(%), so that recorded data ëles can be easily loaded into MATLAB without any modiëcation
required.

Saving Recorded Data

When enough data has been collected, you may stop the recording and save the recorded data to per-
manent ëles by selectingRecord> Save RecordedData from the menu (or clicking the corresponding
button on the toolbar). A dialog will pop up that will allow you to save all the ëles with a Common
Filename Preëx (which defaults to the current timestamp at the moment Save Recorded Data was
selected). You may use the Common Filename Preëx to put your own appropriate description on that
set of log ëles. You can see the actual ële names that the individual log ëles will be saved to in the
greyed-out boxes below. You may disable the saving of individual log ëles by clearing the "Enabled?"
checkbox next to each one. You may also separately name individual log ëles by clearing the checkbox
for the Common Filename Preëx at the top, at which point you can specify names for individual log
ëles. Checking the Common Filename Preëx box again will revert the names to a common preëx.
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Chapter 6 – Recording Data Logs

Discarding Recorded Data

At any time, you may stop the recording and discard the accumulated data up to that point by selecting
Record > Save Recorded Data from the menu (or by clicking the corresponding button on the
toolbar). e temporary recording ëles will be deleted, and a new recording can be started.

Discarding Recorded Data
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Chapter 7

Sending Command Bytes

Command Bytes are advanced commands which are sent to inkGear modules/headsets in order
to change its state or perform an action. Command Bytes are intended for advanced users who
need to reconëgure their inkGear modules/headsets for some particular purpose not available from
the standard default factory conëguration. Use Command Bytes with caution, as sending improper
command bytes to a inkGear module may put it into an unusable state until it is turned off and
turned back on (inkGear modules always return to their default settings each time they are powered
on).

e following are examples of Command Bytes that are useful inkGear modules (MindSet Pro) with
FWv1.7.13 and earlier. ese headsets do not output raw wave data by default, so these Command
Bytes instruct the headset to begin outputting the raw wave data. To enable:

a) full-resolution raw wave data on a 57.6k MindSet:
send Command Byte: 0x13 (decimal: 19, binary: 00010011b).

b) low-resolution raw wave data on a 9600 or 57.6k MindSet:
send Command Byte: 0x11 (decimal: 17, binary: 00010001b).

inkGear ASICs (MindSets) by default already output all the inkGear Data Types relevant to Neu-
roView (Attention, Meditation, Poor Signal Quality, Raw Wave) at 57.6k baud, so it should typically
NOT be necessary to send Command Bytes to these headsets. If you really need to use Command
Bytes, please refer to the Communication Protocol document that accompanied your inkGear head-
set, module, or chip (i.e. the MindSet Communications Protocol) for full details on how other Com-
mand Bytes are formed and to see which commands are available and applicable to your particular
module/headset model and version.
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Chapter 8

Troubleshooting

• If the program inexplicably hangs or freezes sometimes when attempting to connect to a headset,
it may be due to a conìict from a previously installed version of NeuroView. If this is the case,
try uninstalling NeuroView by running the unins000.exe in the Program Files/NeuroView
directory, and then reinstalling NeuroView according to the Installation instructions above once
again.
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